LINUXTALKS.CO

васяносборка

 , ,


0

0

Есть такой pisiman – набор для сборки iso из pisi-пакетов. Вот моя поделка https://sourceforge.net/projects/lxdeside/files/lxdeside/iso/2.3/.

Что имеем?

  • Самый актуальный гтк3 LXDE, больше нигде нет.
  • Нормальный live.
  • usb-modeswitch

– Всякий софт

  • inkscape
  • azpainter
  • viewnior
  • geeqie
  • audacious
  • mpv
  • xscreensaver
  • gparted
  • htop
  • lf
  • cups
  • zim
  • geany
  • poedit
  • zathura
  • xarchiver
  • shutterbug
  • firefox
  • claws-mail
  • transmission

– Глюки yali-установщика
– Долгий запуск некоторых приложений
– Дефолтный внешний вид, только рамочки окон и шрифты подкрутил

На скрине уже не совсем дефолт: обоина стырена с табуна, тема wm – pwm-p. Намучился с своей новой б/у мат. платой(?), чего ни ставлю, ничего не загружается. Положение исправила переустановка grub из yali-rescue.

Надо бы, наверно, рассказать, как работать с этим pisiman, да же? Ну, pisiman это часть репозитория iso-work. Клонируем его, даем права на исполнение всем sh-файлам, а также файлу pisiman.py. Выполняем make.sh для установки всяких нужных зависимостей, затем run.sh открывает главное окно. Проще всего открыть готовый minimal-проект и отредактировать его. Поле repository определяет источник пакетов для установки в iso, live iso repo будет доступен в live-системе. В файле pisiman/data/yali/repos.json можно указать свой репозиторий с приоритетом(будет доступен в установленной системе). В меню project обновлям репозиторий и выбираем язык. В вкладке installation collection отмечаем пакеты для установки в образ и иконку. Сохраняем проект и запускаем сборку project -> make image.

>>> Просмотр (1680x1050, 1528 Kb)



Проверено: cocucka ()
Ответ на: комментарий от odalist

Да. Полгода полет нормальный.

Компоненты DE все последних стабильных версий. Из git добавлены только три патча в lxpanel, исправляющие сломанные pager, taskbar и индикатор громкости(но в сборке volumeicon), и по одному в libfm и lxsession, вносящие небольшие косметические изменения.

Android / ChromeOpera

zombi_pony    

Последнее исправление: zombi_pony (всего исправлений: 2)

Android / Chrome
Ответ на: комментарий от debian000

Потому что пакеты LXQt в коммьюнити pisilinux сопровождает другой человек.

zombi_pony    

Linux / Firefox
Ограничение на отправку комментариев: только для зарегистрированных пользователей, score>=90